Сообщения без ответов | Активные темы Текущее время: 11 июл 2020, 05:51



Ответить на тему  [ 1 сообщение ] 
Подключение SpRecord к 1С 7.7 
Автор Сообщение

Зарегистрирован: 19 дек 2013, 19:53
Сообщения: 1
Сообщение Подключение SpRecord к 1С 7.7
К сожалению напрямую использовать SDK в 1С 7.7 нельзя. Нужно писать компоненту для 1С, которая в свою очередь вызывает функции SDK. В данном примере компонента поддерживает 2 функции - подключение (инициализация) и считывание входящего номера из стека SDK. Исходники dll для Delphi во вложенном файле.

Процедура Сформировать()
имяф=КаталогИБ()+"Spaon.dll";
Если ФС.СуществуетФайл(имяф)=0 Тогда
Сообщить("Не найден файл внешней компоненты "+имяф); а=1/0;
КонецЕсли;

Если ЗагрузитьВнешнююКомпоненту(имяф)=0 Тогда
Сообщить("Ошибка при загрузке внешней компоненты "+имяф); а=1/0;
КонецЕсли;

Попытка
vk = СоздатьОбъект("AddIn.Spaon");
Исключение
Сообщить("Не удается создать объект AddIn.Spaon... !!");
Сообщить("Зайдите в Windows под правами локального администратора и повторите попытку."); а=1/0;

КонецПопытки;

Сообщить(vk.Версия);

vk.Подключить();
КонецПроцедуры

Процедура Проверка()
vk.Проверить();
Если СокрЛП(vk.Номер)<>"" Тогда
Сообщить(vk.Номер);
vk.Номер="";
КонецЕсли;
КонецПроцедуры


Вложения:
SpAON.zip [244.02 КБ]
Скачиваний: 899
19 дек 2013, 20:06
Профиль
Показать сообщения за:  Поле сортировки  
Ответить на тему   [ 1 сообщение ] 

Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.
Русская поддержка phpBB